Persyaratan Sistem

Hosting
Untuk menginstal dan menjalankan web Drupal, hosting Anda harus memenuhi persyaratan minimum tertentu. Kebanyakan web hosting memenuhi persyaratan ini. Namun, beberapa menonjol dengan juga turut mendukung komunitas Drupal. Jika Anda membutuhkan hosting, Anda dapat mempertimbangkan penilaian dan rekomendasi dari komunitas.

Persyaratan Minimum
(Klik per bagian untuk informasi rinci)

Kapasitas disk
15 Megabyte untuk instalasi dasar minimum, 60 MB dengan modul dan tema kontribusi dalam jumlah banyak, dan kapasitas dalam jumlah yang lebih lagi untuk isi database, media, backup dan file lainnya.

Server Web
Apache, Nginx, atau Microsoft IIS

Server Database

  • Drupal 6: MySQL 4.1 atau lebih tinggi, PostgreSQL 7.1,
  • Drupal 7: MySQL 5.0.15 atau lebih tinggi dengan PDO, PostgreSQL 8.3 atau lebih tinggi dengan PDO, SQLite 3.3.7 atau lebih tinggi

Catatan: Microsoft SQL Server dan Oracle didukung oleh modul tambahan

PHP

  • Drupal 6: PHP 4.4.0 atau lebih tinggi (5.2 direkomendasikan)
  • Drupal 7: PHP 5.2.5 atau lebih tinggi (5.3 dianjurkan) - beberapa modul memerlukan 5.3
  • Drupal 8: PHP 5.3.5 atau lebih tinggi

Drupal 8 tidak bisa diinstal pada hosting dengan 'magic_quotes_gpc' atau 'magic_quotes_runtime' pada pengaturan inisial PHP yang dihidupkan; pengaturan ini  telah usang dalam PHP 5.3 dan tidak berpengaruh lagi di PHP 5.4.

Catatan: Jika Anda memenuhi persyaratan, namun masih memiliki masalah dengan situs Anda, pastikan untuk membaca melalui Webhosting Troubleshooting FAQ.

" style="display: none;">Honeypot